Forum Noamweb

move _ uploaded _ file

stringhi - 27/4/2011 at 10:00

Ho postato nella sezione OT del codice (http://forum.noamweb.com/viewthread.php?tid=1095)
per l'upload dei file via php. Noto che, facendo del debug, la funzione move_uploaded_file non funziona. Sembra quasi non venga nemmeno presa in considerazione. Qualcuno sa il perchè? Sulla guida di PHP dice solo che con safe_mode ON bisogna garantire lo stesso UID. Vuol dire che devo generare una session ecc? o non è necessario?
Grazie.

Shazan - 27/4/2011 at 16:47

Salve Stringhi,

io credo che questo tipo di informazioni, relative alla programmazione, abbiano più probabilità di essere risolte in un forum come quello di html.it

Quello che posso suggerirti è provare a disattivare il safe_mode sul dominio e vedere se questo risolve il problema, oppure a configurare il dominio come FastCGI anziché come modulo di Apache (o viceversa).

:saluto:

stringhi - 28/4/2011 at 09:53

Quindi escludete problemi ad utilizzare tale istruzione (move_uploaded_file) legati all'installazione di php sul server ares?
In questo caso è giusto che mi rivolga altrove.
Strano cmq che su easyphp funziona tuttok (però non so se c'è impostato safe_mode on o off)
per modificare il safemode si fa via ticket vero?

Shazan - 28/4/2011 at 13:45

Noi non abbiamo disattivato la funzione in questione ma in ogni caso il debug va prima fatto a livello di programmazione, se poi dovesse occorrere qualche modifica alla configurazione del server, è sempre l'utente che deve farcene esplicita richiesta.

Il safe_mode e la modalità con cui gira PHP, da Plesk 8.2 in poi, è il cliente stesso che può modificarli tra le impostazioni dell'hosting del dominio, mentre per le versioni precedenti di Plesk occorre aprire un ticket.

:saluto: