Forum Noamweb
Non sei collegato [Login - Registrati]
Vai alla fine

Versione per la stampa  
Autore: Oggetto: Problemi Joomla
AscomRa
sono appena arrivato
*




Risposte: 4
Registrato il: 23/2/2009
Utente offline


[*] Inviato il 10/2/2010 at 12:47
Problemi Joomla


Salve a tutti,
espongo il mio problema.
Abbiamo diversi siti hostati su piattaforma linux con pannello Plesk.
Tutti i nostri siti vengon creati in locale su macchina windows con applicativo xampp.
Una volta che il sito completo,via ftp viene caricato tutto sul server host e modificati i valori dei path assoluti ecc per il corretto funzionamento.
Se il sito non riceve modifiche,allora tutto funziona correttamente.

Se altrimenti dobbiamo aggiungere dei moduli ecc, non ci mai possibile poterlo fare per problemi di permessi sulle cartelle.

Abbiamo provato ad impostare a 777 tutte le cartelle uploadate sotto httpdocs ma il risultato non cambia.

possibile che joomla non sia supportato su questi server?

altrimenti come posso fare a fare una installazione corretta? uplodo il file zippato sul server e tramite un script da cron lo scompatto in modo che prenda come owner un altro utente?

insomma non sappiamo pi ogni volta come fare,non ammissibile scaricare ogni volta il sito in locale,installare i moduli e poi riapplodarlo tutto.

Questo genere di problemi non li abbiamo per esempio su altri host sempre su base linux .

grazie per una possibile risposta!
View User's Profile Scorri tutte le risposte per utente
Aulenta
Moderatore
******


Avatar


Risposte: 934
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 10/2/2010 at 13:57


Ciao,
per risolvere il problema sufficiente impostare il safe_mode di PHP su Off. A seconda della versione di Plesk, puoi farlo tu stesso o chiederlo a noi via ticket
http://www.noamweb.com/contatti-assistenza.shtml
specificando il dominio.

:saluto:




http://www.noamweb.com
Hosting, housing e registrazione domini
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
AscomRa
sono appena arrivato
*




Risposte: 4
Registrato il: 23/2/2009
Utente offline


[*] Inviato il 11/2/2010 at 08:18


Buongiorno, grazie della tempestiva risposta.
Ho provato a disabilitare il safe_mode di PHP come suggerito.
Provando ora ad installare un componente su joomla ottengo il seguente errore:
JInstaller::install: Il file /var/www/vhosts/terziariodonna.ra.it/httpdocs/tmp/install_4b73ac76e2a6f/install.oziogallery2.php non esiste
componente Installa: Impossibile copiare il file installazione PHP.
Faccio presente che ho provato ad installare lo stesso componente su un sito in host su Aruba e non ho avuto problemi!
View User's Profile Scorri tutte le risposte per utente
Aulenta
Moderatore
******


Avatar


Risposte: 934
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 11/2/2010 at 11:54


Ciao,

questo perch ogni fornitore sceglie un diverso livello di sicurezza, e questo un punto a cui noi teniamo molto.
Ad ogni modo ti consigliamo di accertarti che la directory tmp esista e che abbia i permessi corretti. Oltre a disabilitare il safe_mode infatti i permessi devono comunque essere corretti.

:splendente:




http://www.noamweb.com
Hosting, housing e registrazione domini
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
AscomRa
sono appena arrivato
*




Risposte: 4
Registrato il: 23/2/2009
Utente offline


[*] Inviato il 11/2/2010 at 12:07


Non vorrei essere frainteso, apprezzo molto il fatto della sicurezza ed infatti questo stato uno dei punti per il quale come azienda abbiamo deciso di appoggiare tutti i ns siti su di voi. Quello che per gradirei comunque sapere come mi devo muovere per non trovare problemi nell'inserimento dei componenti o dei moduli sulla piattaforma di joomla. Inoltre ho verificato la presenza della directory tmp senza per ottenere nessun esito positivo nell'installazione del componente oggetto della discussione. Certo di un suo suggerimento, la saluto Cordialmente!
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1430
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 11/2/2010 at 15:32


Come diceva la collega, occorrono soltanto due cose per far funzionare correttamente Joomla, ossia safe_mode su Off e che i permessi siano corretti. Se Joomla non riesce a scrivere su tmp, l'unico motivo per cui non riesce a farlo per via di permessi errati.

Nel file di log spesso si trovano informazioni utili per capire la natura del problema.

:saluto:




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
AscomRa
sono appena arrivato
*




Risposte: 4
Registrato il: 23/2/2009
Utente offline


[*] Inviato il 11/2/2010 at 16:20


Quota:
Originally posted by Shazan
Come diceva la collega, occorrono soltanto due cose per far funzionare correttamente Joomla, ossia safe_mode su Off e che i permessi siano corretti. Se Joomla non riesce a scrivere su tmp, l'unico motivo per cui non riesce a farlo per via di permessi errati.

Nel file di log spesso si trovano informazioni utili per capire la natura del problema.

:saluto:


sia la cartella tmp che log impostata con permessi 777.
Nel file di log non sono presenti errori,si nella cartella log di httpds ne nella gestione plesk. non riesco a capire a sto punto da dove nasca il problema
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1430
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 11/2/2010 at 16:27


Il problema potrebbe nascere da precedenti installazioni non andate a buon fine. In questo caso sarebbe meglio svuotare tutta la directory e riprovare con il safe_mode su Off da zero, dopo aver avuto la certezza che httpdocs sia completamente vuota.



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente

  Vai all'inizio

Powered by XMB 1.9.11
XMB Forum Software © 2001-2012 The XMB Group