Forum Noamweb
Non sei collegato [Login - Registrati]
Vai alla fine

Versione per la stampa  
Autore: Oggetto: PHP 5
braidiano
vengo ogni tanto
**




Risposte: 12
Registrato il: 19/10/2004
Utente offline


[*] Inviato il 17/11/2004 at 18:35
PHP 5


Ciao.

vorrei chiedervi se avete in programma di attivare il supporto a PHP 5 su linux e/o su windows.

Grazie e complimenti per il servizio, sempre celere ed efficiente.

:saluto:
View User's Profile Scorri tutte le risposte per utente
Aulenta
Moderatore
******


Avatar


Risposte: 934
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 17/11/2004 at 19:52


Ciao,

grazie per i complimenti, fanno sempre piacere! ;)
Riguardo alla tua richiesta, effettuiamo sempre upgrade alle versioni più recenti e stabili che siano compatibili con i pannelli di controllo, tuttavia abbiamo ricevuto richieste da parte di clienti di procrastinare l'ultimo upgrade previsto (vedi per es. il post http://forum.noamweb.com/viewthread.php?tid=37) per cui abbiamo rimandato per dar loro maggior tempo per organizzarsi di conseguenza.
In ogni caso gli upgrade vengono effettuati periodicamente (solo a verioni stabili e compatibili con i pannelli, ovviamente), per cui sono solo rimandati e non cancellati.
:saluto:

[Modificato il 17-11-2004 da Aulenta]




http://www.noamweb.com
Hosting, housing e registrazione domini
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
mplab
vengo ogni tanto
**




Risposte: 9
Registrato il: 3/3/2006
Utente offline


[*] Inviato il 7/5/2007 at 19:03


Scusate l'intrusione, ma non si potrebbe avere sia PHP4 che PHP5?

io avrei da consigliare 2 soluzioni

SOLUZIONE NR. 1
Sul mio server in ufficio i files con estensione .php vengono eseguiti con PHP4, quelli con estensione .php5 con l'omonima versione.

Naturalmente, il mio server è solo un ambiente di sviluppo... ma non credo ci possano essere problemi sul vostro server.
(E' anche vero che diventa una procedura fastidiosa per gli utenti che devono rinominare numerosi file con l'estensione .php in .php5 ma se ne hanno davvero l'esigenza almeno hanno una possibilità)

SOLUZIONE NR. 2
Un altra soluzione sarebbe l'installazione sul server di una pacchetto di PEAR (ho controllato... attualmente non è installato sul vostro server) che consente di utilizzare quasi tutte le funzioni (forse anche tutte) di PHP5 in PHP4 senza necessità di upgrade della versione di php.

Se non ricordo male il pacchetto si chiama php_compact... ma non l'ho mai utilizzato quindi non sono in grado di confermare se realmente funge :-)

ciao a tutti
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente Questo utente ha un indirizzo MSN
Aulenta
Moderatore
******


Avatar


Risposte: 934
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 7/5/2007 at 19:34


purtroppo utilizzando un pannello di controllo, non si ha la stessa libertà di manovra che si potrebbe avere su un server che ne sia sprovvisto, pertanto se non si tratta di un'opzione prevista dal pannello ciò può creare seri malfunzionamenti...:spiazzato:



http://www.noamweb.com
Hosting, housing e registrazione domini
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
mplab
vengo ogni tanto
**




Risposte: 9
Registrato il: 3/3/2006
Utente offline


[*] Inviato il 7/5/2007 at 19:57


vabbè ma l'installazione del pacchetto di pear però è fattibile.... l'ultima volta non ho fatto in tempo a richiedere l'installazione di un pacchetto che già avevate finito... quindi adesso dov'è il problema? (è un pacchetto complicato? :) scherzo)
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente Questo utente ha un indirizzo MSN

  Vai all'inizio

Powered by XMB 1.9.11
XMB Forum Software © 2001-2012 The XMB Group