Forum Noamweb
Non sei collegato [Login - Registrati]
Vai alla fine

Versione per la stampa  
 Pagine:  1  
Autore: Oggetto: Inserire formmail di Matt Wright
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 14:30
Inserire formmail di Matt Wright


Ciao, vorrei pubblicare un modulo formmail che si basa su formmail.pl di Matt Wright, vorrei gentilmetne sapere qual'è la stringa iniziale da inserire nello script, cioè dove sono posizionate le librerie perl sui vostri server,
nel file originale è così:
#!/usr/bin/perl

Grazie
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 17:53


Ciao pinop,

va bene il percorso così com'è indicato nel file originale.

:saluto:




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


sad.gif Inviato il 12/3/2006 at 18:03
Però non funziona...


Però non funziona, :spiazzato: mi viene editato e visualizzato sendmail.pl, come se non venisse elaborato.
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 18:04


In quale cartella è stato pubblicato?



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 18:08
Formmail


Nella cartella cgi-bin
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 18:13


posti il link per favore?



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 18:22
questo è il link


Il link è:

questo è il link

è solo una prova per questo le img non si vedono :singing:
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 18:25


Ma nell'html c'è questo percorso: http://www.capo-vaticano.com/formmail.pl

Non può funzionare perché il formmail deve trovarsi all'interno della cartella cgi-bin, e a quest'indirizzo http://www.capo-vaticano.com/cgi-bin/formmail.pl il formmail non c'è...




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 18:44
grazie


Innanzi tutto grazie per l'assistenza, e, considerando che oggi è domenica, fa guadagnare 1000 punti alla vostra professionalità :singing:.

Torniamo al probelema , la cartella cgi-bin, è quella che mi trovo sul server nello spazio relativo al dominio in oggetto, o devo creare io un'altra cartella di nome cgi-bin all'interno di httpdocs?
Nel file html ho cambiato il percorso in

ho posizionato il file formmail.pl all'interno di cgi-bin sul server, ma adesso mi da solo una pagina d'errore:
Eccola
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 18:47


Occorre utilizzare quella creata in automatico dal server, se ne hai creata un'altra dovresti eliminarla altrimenti il server non trova più quella corretta.

Grazie per i complimenti comunque :)




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 19:00
non funziona


questa è la linea nel file html:



il file formmail.pl è in cgi-bin nella cartella di default, ho cancellato quella che ho creato io, ma non funziona :confuso:

adesso è una questione di principio :splendente::splendente:
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 19:01


Non funziona perché ho appena visto che non hai messo il supporto CGI e mod_perl sull'account in questione... Nel frattempo sposto nell'area giusta il thread visto che riguarda Linux con pannello Plesk e non CPanel.

[Modificato il 12-3-2006 da Shazan]




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 19:03


FORM ACTION="./cgi-bin/formmail.pl" method=POST

scusa questa è la linea (con <> sennò non si vede :splendente:
View User's Profile Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 19:04


dovete attivarlo voi il supporto o devo farlo io? :bacino:
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 19:05


Il reseller ovviamente, non noi.



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 19:10
finalmente .... un'errore diverso


Fatto ho attivato e: finalmente un'errore diverso :singing::singing::singing:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, papaianni@email.it and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log

E già una piccola soddisfazione :singing::singing:
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 19:12


Hai fatto l'upload nella modalità sbagliata... (ASCII/binario)



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 19:18


ma, va fatto in ascii o non va fatto?

io l'avervo fatto in ascii come ho letto sul sito del formmail:sigh:
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 19:18


Inoltre occorre aggiungere il permesso di esecuzione (x) tramite il comando CHMOD del client FTP.



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 19:28


Ho settato i permessi, ho ulodato in ascii ma l'errore è lo stesso, errore del server, l'unica mia soddisfazione è che stiamo scrivendo un compendio di cosa non bisogna fare per pubblicare un formmail :singing: spero almeno di essere d'aiuto per il prossimo :bacino:
Pensavo che magari può essere qualche errore all'interno del file formmail.pl cosa ne pensi?
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 19:31


Non è mai accaduto, comunque puoi consultare i file di log.



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 19:40


[Sun Mar 12 19:37:09 2006] [error] [client 87.6.116.64] Premature end of script headers: formmail.pl

Questo è il msg del file di log
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 19:41


Si tratta di caratteri estranei. Forse hai modificato il file con il notepad...? Meglio usare Wordpad.



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
pinop
vengo ogni tanto
**




Risposte: 16
Registrato il: 12/3/2006
Utente offline


[*] Inviato il 12/3/2006 at 19:56


mi arrendo, ho riscaricato il file, aggiornato i parametri, aperto con wordpad, salvato e uplodato in ascii, settato i parametri a chmod 755 ma niente, :sigh::sigh::sigh:
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 12/3/2006 at 20:15


In questi casi, per essere certi che si tratti di un problema sorto in seguito ad una modifica da noi operata, è meglio provare a fare l'upload del file originale *senza modificarlo*. Se così funziona mentre dopo averlo modificato non funziona più, significa che abbiamo sbagliato qualcosa noi durante la modifica.



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
 Pagine:  1  

  Vai all'inizio

Powered by XMB 1.9.11
XMB Forum Software © 2001-2012 The XMB Group