Forum Noamweb
Non sei collegato [Login - Registrati]
Vai alla fine

Versione per la stampa  
Autore: Oggetto: IMPORTANTE: Non utilizzate ODBC per connettervi ai db Access!
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 21/10/2004 at 16:15
IMPORTANTE: Non utilizzate ODBC per connettervi ai db Access!


Siete pregati di non utilizzare ODBC per connettervi ai vostri database Access in quanto si tratta, come dichiarato dalla stessa Microsoft all'URL http://support.microsoft.com/default.aspx?scid=kb;EN-US;2999... , di un metodo particolamermente inadatto all'utilizzo in un ambiente in cui avvengono numerose connessioni contemporanee.

Come potete leggere dall'articolo in questione, i risultati possono essere imprevedibili!

Al posto di ODBC, vi preghiamo dunque di utilizzare OLE-DB. Se vi occorrono ulteriori approfondimenti al riguardo, vi segnalo l'ottimo articolo pubblicato su ASPItalia.com all'url http://www.aspitalia.com/articoli/db/ole-db.aspx .

:saluto:




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Rossoweb
vengo ogni tanto
**


Avatar


Risposte: 21
Registrato il: 6/10/2004
Utente offline


[*] Inviato il 3/11/2004 at 23:50


Salve, volevo chiedere se era possibile utilizzare il provider OLE DB anche per le connessioni ai db MySql, o meglio vorrei sapere se è installato il driver MyOLEDB 2.5 o megli ancora il 3.0.

Ciuaz :saluto:




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 4/11/2004 at 11:21


Salve,

i problemi di instabilità sembrano riguardare prevalentemente l'utilizzo di ODBC con Access. Non sembrano esserci problemi con MySQL.

:saluto:




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Rossoweb
vengo ogni tanto
**


Avatar


Risposte: 21
Registrato il: 6/10/2004
Utente offline


[*] Inviato il 4/11/2004 at 12:10


Si infatti, ODBC va benissimo con MySQL, è solo per una questione di velocità.

Per me (credo anche per gli altri programmatori che hanno siti sul server), non ci sono grosse differenze ad utilizzare l'una o l'altra connessione ad db in fase di programmazione; l'interesse ad OLE DB è dato solo dal fatto che è molto più veloce nell'eseguire le query e questo avrebbe permesso un minor carico al server ;)

Con questo non vuol dire che mi sto lamentando, anzì..., il servizio è più che ottimo già così.

Con simpatia... ciauz :saluto:




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Wildsun_it
vengo ogni tanto
**




Risposte: 10
Registrato il: 3/2/2005
Utente offline


[*] Inviato il 3/2/2005 at 10:24


Ciao a tutti
utilizzando degli script precompilati in asp, riscontro grosse difficoltà sia nella connessione al database (in parte risolta utilizzando il percorso assoluto del database) sia di lettura e scrittura.
Il messaggio che viene visualizzato è "HTTP 500 - Errore interno del server". Il problema non si verifica se lo stesso script viene installato su Windows 2000. Potete aiutarmi?
Grazie:cool:




Wildsun_it
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 3/2/2005 at 10:40


Quota:
Originally posted by Wildsun_it
Il messaggio che viene visualizzato è "HTTP 500 - Errore interno del server". Il problema non si verifica se lo stesso script viene installato su Windows 2000. Potete aiutarmi?
Grazie:cool:

Iniziamo impostando in maniera appropriata il browser...
Con molta probabilità hai i messaggi di errore brevi nelle impostazioni avanzate di Internet Explorer, per cui non vedrai mai il vero messaggio d'errore...




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Wildsun_it
vengo ogni tanto
**




Risposte: 10
Registrato il: 3/2/2005
Utente offline


[*] Inviato il 3/2/2005 at 11:13


Grazie mille!
Ho disabilitato gli errori brevi e ho cominciato a ricodificare lo script.
Tra gli errori, ora mi visualizza che è impossibile trovare un file.inc che però è presente nella cartella.
Ora, ho provato ad utilizzare sia il percorso virtuale che quello reale.
Risultato: NIENTE!!!
cosa dovrei fare?
Grazie




Wildsun_it
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 3/2/2005 at 11:19


Cosa dice il messaggio d'errore con esattezza? Le parole precise.



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Wildsun_it
vengo ogni tanto
**




Risposte: 10
Registrato il: 3/2/2005
Utente offline


[*] Inviato il 3/2/2005 at 11:27


Active Server Pages error 'ASP 0126'

Include file not found

/xxxxxxxxxxx, line 3

The include file 'C:\xxxxxxxxxxxxxxxx' was not found.

[Modificato il 3-2-2005 da Shazan]




Wildsun_it
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Wildsun_it
vengo ogni tanto
**




Risposte: 10
Registrato il: 3/2/2005
Utente offline


[*] Inviato il 3/2/2005 at 11:27


Active Server Pages error 'ASP 0130'

Invalid File attribute

/xxxxxxxxxxxxx, line 3

File attribute '/xxxxxxxxxxxxxx' cannot start with forward slash or back slash.

[Modificato il 3-2-2005 da Shazan]




Wildsun_it
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Wildsun_it
vengo ogni tanto
**




Risposte: 10
Registrato il: 3/2/2005
Utente offline


[*] Inviato il 3/2/2005 at 11:28


Active Server Pages error 'ASP 0131'

Disallowed Parent Path

/xxxxxxxxxxxxx, line 3

The Include file '../../xxxxxxx' cannot contain '..' to indicate the parent directory.

[Modificato il 3-2-2005 da Shazan]




Wildsun_it
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 3/2/2005 at 11:39


Se usi "#include FILE" prova con "#include VIRTUAL" al suo posto.

Ho censurato le informazioni sensibili presenti nei tuoi post.




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 3/2/2005 at 11:44


Con "#include VIRTUAL" il percorso è relativo a quello che appare nella barra dell'indirizzo. In pratica www.dominio.ext/cartella1/cartella2/file si include semplicemente con "/cartella1/cartella2/file".



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 3/2/2005 at 11:51


Comunque, non c'è alcun legame tra questi errori ed il sistema operativo.
Il problema è che lo script che stai cercando di installare è scritto male.
Ti suggerisco di consultare delle guide sulla programmazione di pagine ASP o di chiedere aiuto ad altri programmatori come quelli che frequentano il forum di webmasterpoint.org ( http://forum.webmasterpoint.net/ ) o di HTML.iT ( http://forum.html.it/forum/ ).




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Wildsun_it
vengo ogni tanto
**




Risposte: 10
Registrato il: 3/2/2005
Utente offline


[*] Inviato il 3/2/2005 at 12:13


niente da fare ... sto pensando quasi a rinunciare :spiazzato:



Wildsun_it
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Wildsun_it
vengo ogni tanto
**




Risposte: 10
Registrato il: 3/2/2005
Utente offline


[*] Inviato il 3/2/2005 at 12:19


ma se su win2k funziona senza fare alcuna modifica xchè sul 2003 rompe??? vabbè grazie per l'attenzione!



Wildsun_it
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 3/2/2005 at 12:25


Perché chi l'ha fatto l'ha provato solo su Windows 2000 evidentemente...



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Wildsun_it
vengo ogni tanto
**




Risposte: 10
Registrato il: 3/2/2005
Utente offline


[*] Inviato il 3/2/2005 at 13:33


RISOLTOOOOOOOOOO!!!
Grazie, ora smanetto un pò per risolvere qualche problemino, ma tutto ok.
Grazie Mille




Wildsun_it
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Wildsun_it
vengo ogni tanto
**




Risposte: 10
Registrato il: 3/2/2005
Utente offline


[*] Inviato il 3/2/2005 at 13:54


Un'ultima cosa:
è possibile sostituire la stringa
Connect.Open "driver={Microsoft Access Driver (*.mdb)};dbq=C:\domains\dominio.it\db\database.mdb"
con una stringa tipo
Connect.Open "driver={Microsoft Access Driver (*.mdb)};dbq=/db/database.mdb"
al fine di riscrivere per ogni script il dominio?
Grazie




Wildsun_it
View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 4/2/2005 at 08:28


Ti prego di rileggere bene il primo post perché sono entrambe vietate.
Occorre usare una stringa OLE-DB anziché ODBC.




View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Bob77
vengo ogni tanto
**




Risposte: 5
Registrato il: 25/5/2005
Utente offline


[*] Inviato il 25/5/2005 at 16:57


Siccome ho perso un po' di tempo a farlo funzionare (soprattutto non sapevo il percorso del db sul server), scrivo per tutti la stringa di connessione che ho usato e che funziona,


<%MM_connessione_STRING = "Provider = Microsoft.Jet.OLEDB.4.0;Data Source = C:\domains\nomedominio.it\db\nomedb.mdb;Persist Security Info = False"
%>

Ciao
View User's Profile Scorri tutte le risposte per utente
andy
vengo ogni tanto
**




Risposte: 14
Registrato il: 19/10/2005
Utente offline


[*] Inviato il 21/10/2005 at 10:19


ciao, c'è qualcuno che darebbe il percorso fisico per connettersi al db tramite OLEdb ?
SAREBBE UTILE DAVVERO A MOLTI.....

grazie! ;)
View User's Profile Scorri tutte le risposte per utente
Shazan
Super Amministratore
*********


Avatar


Risposte: 1426
Registrato il: 5/10/2004
Utente offline


[*] Inviato il 21/10/2005 at 12:16


Dal momento che il percorso fisico degli account può variare da un server ad un altro, è molto meglio se lo chiedete a noi via email specificando il nome del vostro dominio.



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente
Rajesh
sono appena arrivato
*




Risposte: 1
Registrato il: 16/5/2013
Utente offline


[*] Inviato il 16/5/2013 at 10:03


Un'applicazione ASP stabilisce la connessione a un database mediante un driver ODBC (Open Database Connectivity) o mediante un provider OLE DB (Object Linking And Embedding Database). Il driver o il provider funge da interprete e consente la comunicazione tra l'applicazione Web e il database. La tabella seguente mostra alcuni driver utilizzabili con database di Microsoft Access, SQL Server e Oracle.Embedded Software



View User's Profile Visita la pagina dell utente Scorri tutte le risposte per utente

  Vai all'inizio

Powered by XMB 1.9.11
XMB Forum Software © 2001-2012 The XMB Group