Forum Noamweb

da aruba a noam ma i db?

andy - 19/10/2005 at 15:19

Ho avuto sempre siti in gestione su aruba e in quel server esisteva una cartella mdb-database creata esclusivamente per i db.Qui come posso crearla? vorrei fare un c onnessione ole dato che il db è access ho creato la cartella virtuale ed aggiornato la cartella via ftp ma non riesco ad accedervi come percorso...

Shazan - 19/10/2005 at 15:39

Salve,

non serve la cartella mdb-database. Abbiamo già trattato l'argomento in questo post: http://forum.noamweb.com/viewthread.php?tid=461 .

Buon lavoro!

:saluto:

ok ma non la trovo

andy - 19/10/2005 at 16:51

"Provider = Microsoft.Jet.OLEDB.4.0; Data Source = /mdb-database/Acc_idea.mdb; Persist Security Info = False"

questa la mia stringa mentre:

Microsoft JET Database Engine error '80004005'

'c:/mdb-database/Acc_idea.mdb' is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.

/contatti.asp, line 14

questo l'errore che ricevo scusate forse è una cosa banale..

Grazie cmq...:umm:

Shazan - 19/10/2005 at 17:05

Come dicevo in precedenza, la cartella "mdb-database" non esiste, puoi mettere il db nella cartella che desideri ed inserire quella cartella nel percorso della stringa di connessione.
Ti consiglio di provare a metterla nella stessa cartella degli script e, quando sarai riuscito ad accedervi, di spostarla in una più sicura.

:saluto:

umm...

andy - 19/10/2005 at 18:10

alt..ma io sto mettendo tutto nella cartella httpdocs(corretto???) infatti la cartella md-database esiste la ho messa io...ho pravato a metter il db solo ma mi dica file nontrovato ecco il dubbio...

Shazan - 19/10/2005 at 18:22

Stiamo parlando di un account con il pannello di controllo PLESK, giusto?

Se sì, httpdocs è la cartella giusta ma nel messaggio d'errore che hai postato si legge:
'c:/mdb-database/Acc_idea.mdb' is not a valid path.
Perché "C:"? Nella stringa di connessione che hai postato non c'è "C:". Sicuro che stai lavorando sul file giusto?

Fra l'altro il percorso assoluto parte da D: in quanto i domini non si trovano su C ma su D, quindi dubito che il percorso sia stato dedotto da ASP. Da qualche parte hai erroneamente inserito C: nel percorso.

[Modificato il 19-10-2005 da Shazan]

ancora niente

andy - 20/10/2005 at 10:36

questa l amia nuova stringa:

Provider = Microsoft.Jet.OLEDB.4.0; Data Source = Acc_idea.mdb; Persist Security Info = False

questo quello che ottengo

Microsoft JET Database Engine error '80004005'

Could not find file 'c:\windows\system32\inetsrv\Acc_idea.mdb'.


ancora C! :confuso:

Shazan - 20/10/2005 at 16:09

Perchè non usi un DSN? Così eviti questi problemi con i percorsi.

:saluto:

andy - 20/10/2005 at 16:25

beh tu stesso suggerisci di usare OLE effettivamente più performante....

Shazan - 21/10/2005 at 12:10

Il mio era un rimedio estremo e temporaneo, in ogni caso mi risulta che il percorso completo ti sia stato inviato via email.

:saluto:

infatti ecco la stringa per tutti

andy - 21/10/2005 at 14:19

D:\vhosts\sito.it\httpdocs

grazie:appaluso: